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Mixed-effects models for categorical outcomes

• dichotomous outcomes

– mixed-effects logistic regression

• ordinal outcomes

– mixed-effects ordinal logistic regression

∗ proportional odds model

∗ partial or non-proportional odds model

• nominal outcomes

– mixed-effects nominal logistic regression

• discrete or grouped time-to-event data

– mixed-effects dichotomous or ordinal regression

∗ complementary log-log link for proportional (and
non-proportional) hazards models
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Logistic Regression Model

log


P (Yi = 1)

1− P (Yi = 1)

 = x′iβ

• Dichotomous outcome (Y = 0 absence, Y = 1 presence).

• Function that links probabilities to regressors is the logit (or log
odds) function log [P/(1− P ]. Logit is called the link function.

The model can be written in terms of probabilities:

P (Yi = 1) =
1

1 + exp(−x′iβ)

•Model is a linear model for the logits, not for the probabilities.
Logits can take on any values between negative and positive
infinity, probabilities can only take on values between 0 and 1
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Dichotomous Response and Threshold Concept
Continuous yi - an unobservable latent variable - related to
dichotomous response Yi via “threshold concept”

Response occurs (Yi = 1) if γ < yi
otherwise, a response does not occur (Yi = 0)
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The Threshold Concept in Practice
“How was your day?” (what is your satisfaction level today?)

• Satisfaction may be continuous, but we usually emit a
dichotomous response:
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Model for Latent Continuous Responses
Consider the model with p covariates for the latent response
strength yi (i = 1, 2, . . . , N):

yi = x′iβ + εi

• probit: εi ∼ standard normal (mean=0, variance=1)

• logistic: εi ∼ standard logistic (mean=0, variance=π2/3)

⇒ β estimates from logistic regression are larger (in abs. value)
than from probit regression by approximately

√
π2/3 = 1.8

Underlying latent variable

• useful way of thinking of the problem

• not an essential assumption of the model
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Random-intercept Logistic Regression Model

Consider the model with p covariates for the response Yij for subject
i (i = 1, 2, . . . , N) at time j (j = 1, 2, . . . , ni):

log


P (Yij = 1 | υ0i)

1− P (Yij = 1 | υ0i)

 = x′ijβ + υ0i

where

Yij = dichotomous response for subject i at time j

xij = (p + 1)× 1 covariate vector (includes 1 for intercept)

β = (p + 1)× 1 vector of unknown parameters

υ0i = subject effects distributed NID(0, σ2
υ)
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Model for Latent Continuous Responses

Consider the model with p covariates for the ni × 1 latent response
strength yij:

yij = x′ijβ + υ0i + εij

where assuming

• εij ∼ standard normal (mean 0 and σ2 = 1) leads to
mixed-effects probit regression

• εij ∼ standard logistic (mean 0 and σ2 = π2/3) leads to
mixed-effects logistic regression
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Underlying latent variable

• not an essential assumption of the model

• useful for obtaining intra-class correlation (r)

r =
σ2
υ

σ2
υ + σ2

and for design effect (d)

d =
σ2
υ + σ2

σ2 = 1/(1− r)

ratio of actual variance to the variance that would be obtained by
simple random sampling (holding sample size constant)
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Scaling of regression coefficients

β estimates from mixed-effects model are larger (in abs. value) than
from fixed-effects model by approximately

√
d =

√√√√√√√√σ
2
υ + σ2

σ2

because

• V (y) = σ2
υ + σ2 in mixed-effects model

• V (y) = σ2 in fixed-effects model

difference depends on size of random-effects variance σ2
υ
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Treatment-Related Change Across Time

Data from the NIMH Schizophrenia collaborative study on treatment related
changes in overall severity. IMPS item 79, Severity of Illness, was scored as:

1 = normal
2 = borderline mentally ill
3 = mildly ill
4 = moderately ill
5 = markedly ill
6 = severely ill
7 = among the most extremely ill

The experimental design and corresponding sample sizes:

Sample size at Week
Group 0 1 2 3 4 5 6 completers
PLC (n=108) 107 105 5 87 2 2 70 65%
DRUG (n=329) 327 321 9 287 9 7 265 81%
Drug = Chlorpromazine, Fluphenazine, or Thioridazine

Main question of interest:

•Was there differential improvement for the drug groups relative to the control
group?
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• Under SSI, Inc > “SuperMix (English)” or “SuperMix (English) Student”

• Under “File” click on “Open Spreadsheet”

• Open C:\SuperMixEn Examples\Workshop\Binary\SCHIZX1.ss3
(or C:\SuperMixEn Student Examples\Workshop\Binary\SCHIZX1.ss3)
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C:\SuperMixEn Examples\Workshop\Binary\SCHIZX1.ss3
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Select Imps79D column, then “Edit” > “Set Missing Value”
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Select “File” > “Data-based Graphs” > “Bivariate”
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Select “File” > “Data-based Graphs” > “Bivariate”
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Observed proportions ≥ “moderately ill”
week 0 week 1 week 3 week 6

placebo .98 .91 .89 .71
drug .99 .82 .66 .42

Observed odds ≥ “moderately ill”
week 0 week 1 week 3 week 6

placebo 52.5 9.50 7.70 2.50
drug 80.8 4.63 1.93 .73

ratio .65 2.05 3.99 3.42

Observed log odds ≥ “moderately ill”
week 0 week 1 week 3 week 6

placebo 3.96 2.25 2.04 .92
drug 4.39 1.53 .66 -.31

difference -.43 .72 1.38 1.23
exp (odds ratio) .65 2.05 3.99 3.42
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Observed Proportions across Time by Condition

• model is not linear in terms of probabilities

P (Yij = 1 | υ0i) =
1

1 + exp
−

x′ijβ + υ0i


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Observed Logits across Time by Condition

model is linear in terms of logits: log

 P (Yij = 1 | υ0i)
1− P (Yij = 1 | υ0i)

 = x′ijβ + υ0i
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Within-Subjects / Between-Subjects components

Within-subjects model - level 1 (j = 1, . . . , ni obs)

logitij = b0i + b1i
√
Weekj

Between-subjects model - level 2 (i = 1, . . . , N subjects)

b0i = β0 + β2Grpi + υ0i

b1i = β1 + β3Grpi

υ0i ∼ NID(0, σ2
υ)
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Under “File” click on “Open Existing Model Setup”

Open C:\SuperMixEn Examples\Workshop\Binary\schizb1.mum
(or C:\SuperMixEn Student Examples\Workshop\Binary\schizb1.mum)
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Note “Dependent Variable Type” should be “binary”
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Note “Optimization Method” should be “adaptive quadrature”
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SuperMix is FAST for full-likelihood estimation of non-normal
models, and up to three level models
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Empirical Bayes Estimates of Random Effects
Select “Analysis” > “View Level-2 Bayes Results”

ID, random effect number, estimate, variance, name
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Close output, select “File” > “Model-based Graphs” > “Equations”
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Estimated (subject-specific) Logits across Time by
Condition: random-intercepts model

log

 P (Yij = 1 | υ0i)
1− P (Yij = 1 | υ0i)

 = 5.39− .025Di − 1.50Tj − 1.01 (Di × Tj) + υ0i

υ0i ∼ NID(0, σ̂2υ = 4.48)

β̂ change in (conditional) logit due to x for subjects with the same
value of υ0i (the above plot is for υ0i = 0)
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Random-intercepts Logistic Regression

logitij = x′ijβ + υ0i

• every subject has their own propensity for response (υ0i)

• the influence of covariates x is determined controlling (or
adjusting) for the subject effect

• the covariance structure, or dependency, of the repeated
observations is explicitly modeled
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β0 = log odds of response for a typical subject with x = 0 and
υ0i = 0

β = log odds ratio for response associated with unit changes in
x for the same subject value υ0i
∗ referred to as “subject-specific”
∗ how a subject’s response probability depends on x

σ2
υ = degree of heterogeneity across subjects in the probability

of response not attributable to x

• most useful when the objective is to make inference about
subjects rather than the population average

• interest is in the heterogeneity of subjects
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Estimated Subject-Specific Probabilites

P (Yij = 1 | υ0i) =
1

1 + exp [− (5.39− .03Di − 1.50Tj − 1.01DiTj + υ0i)]

where υ0i =


−1συ

1συ
and σ̂υ = 2.12
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Instead of the mixed model, consider the following marginal model

log


P (Yij = 1)

1− P (Yij = 1)

 = x′ijβ
pa

• βpa have marginal or “population-average” interpretation

• Not conditional on subject random effects

• Estimates from a GEE model are of this type

• βss 6= βpa unless random effect variance(s) equal 0 (or β = 0)

⇒ Can one obtain βpa from βss?
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For a random-intercept model with estimates β̂
ss

and σ̂2
υ

β̂
pa ≈ β̂ss/

√√√√√√√√√
σ̂2
υ + π2/3

π2/3

• π2/3 is the variance of the standard logistic distribution

• square-root term on the right-hand side can be viewed as the
“marginalization” factor; transforms subject-specific parameters
into their population-averaged counterparts

• In a random-intercepts model, the variance is equal across time;
marginalization factor is equal across time and is a scalar

• For models with multiple random effects, this is not the case and
so there is no simple relationship
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• Hedeker, du Toit, Demirtas, Gibbons (2014) describe a general
marginalization approach that has been implemented in the
update of Supermix to yield Population Average Estimates
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log


P (Yij = 1)

1− P (Yij = 1)

 = 3.54− .055Di − 1.05Tj − .60 (Di × Tj)

⇒ these are the Population Average Estimates from Supermix
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P (Yij = 1) =
1

1 + exp
[
−

(
3.54− .055Di − 1.05Tj − .60DiTj

)]

⇒ these are the Population Average Estimates from Supermix
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Within-Subjects / Between-Subjects components

Within-subjects model - level 1 (j = 1, . . . , ni obs)

logitij = b0i + b1i
√
Weekj

Between-subjects model - level 2 (i = 1, . . . , N subjects)

b0i = β0 + β2Grpi + υ0i

b1i = β1 + β3Grpi + υ1i

υi ∼ NID(0,Συ)
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Under “File” click on “Open Existing Model Setup”

Open C:\SuperMixEn Examples\Workshop\Binary\schizb2.mum
(or C:\SuperMixEn Student Examples\Workshop\Binary\schizb2.mum)
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Note “Dependent Variable Type” should be “binary”
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SqrtWeek is a level-2 (subject) random effect
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Note “Optimization Method” should be “adaptive quadrature”
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⇒ Comparing models: H0 : σ2υ1 = συ01 = 0; χ2
2 = 1249.73− 1227.76 = 21.97, p < .001
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⇒ Supermix is FAST for a full-likelihood solution using bivariate numerical integration involving

100 quadrature points!
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Empirical Bayes Estimates of Random Effects
Select “Analysis” > “View Level-2 Bayes Results”

ID, random effect number, estimate, variance, name
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Close output, select “File” > “Model-based Graphs” > “Equations”
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Summary - mixed models for binary outcomes

• link functions: logistic, probit, log-log, complementary log-log

• multiple random effects (correlated or independent) for up to
3-level models

• fast full-likelihood estimation using adaptive Gauss-Hermite
quadrature

• subject-specific and population-average estimates and inference

• discrete/grouped time survival analysis via person-period dataset

• Advanced > Level-2 (Co)variance Patterns > Unidimensional

– varying ICC model for MZ/DZ twin pair data: create dummy
variables MZ and DZ, specify both as random effects, select
“Unidimensional”

– Item-response theory (IRT) models: create indicator variables
for items, specify all as random effects, select “Unidimensional”
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