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2 Graphical User Interface 

The SuperMix graphical user interface (GUI) consists of a main window, a 
spreadsheet window, and a graph window. The main window is used to create or 
open SuperMix data files, whereas the spreadsheet window is used to display 
SuperMix data files and to allows access to the Model Setup window. The graph 
window is used to display SuperMix graph files. SuperMix data files have the default 
extension .ss3 and are known as ss3 or spreadsheet files, while SuperMix model files 
have the default extension .mum. SuperMix graph files have the default extension 
.mug. The main window and its menus and dialog boxes are reviewed in the next 
section, and the menus and dialogs of the spreadsheet and graph windows are 
reviewed in the sections to follow. 

 

2.1 The main window 
The SuperMix main window is accessed when you start the program. SuperMix can be 
opened from the Programs option on the Windows Start menu, by double-clicking on 
the SuperMix application or by clicking on a shortcut for SuperMix. Any of these 
actions opens the following main window. 

 

 
 

The SuperMix main window consists of a File menu and a Help menu. These menus 
are reviewed separately in the following two sections. 
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2.1.1 The File menu 

The options on the File menu of the SuperMix main window provide access to a 
sequence of three dialog boxes that can be used to create or to open a SuperMix data 
file in a spreadsheet format.  

 

 
 

The New Spreadsheet option 

Click on the New Spreadsheet option to open an empty SuperMix spreadsheet 
window. 

 

 
 

You can use the window above to enter data manually. Use the Save As option on 
the File menu to save the data to an ss3 file. Alternatively, data can be imported into 
the empty spreadsheet via the File, Import Data File option. 
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The Open Spreadsheet option 

The Open option on the File menu is used to open an existing SuperMix data file. 
Click on the Open Spreadsheet option to load the following Open Spreadsheet 
dialog box. 

 

 
 

Next, browse for the ss3 file, select it, and click on the Open button to open the 
SuperMix spreadsheet window. 

 
The Import Data File option 

Use the Import Data File option on the File menu to convert the data in a Microsoft 
Excel workbook (*.xls), statistical files and databases (SAS, SPSS, etc.) or a comma 
delaminated text file to a SuperMix data file. To import an Excel data file, click on the 
Import Data File option to load the following Open a file to import dialog box. 
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Next, browse for the Microsoft Excel workbook or the text file and select it. Click on 
the Open button to load the Save As dialog box. Enter a name for the ss3 file and 
click on the Save button to open the SuperMix data file in a spreadsheet window. 

 
The Exit option 

Close the SuperMix main window by clicking on the Exit option on the File menu. 

2.1.2 The Help menu 

The options on the Help menu on the SuperMix main window provide access to the 
contents of the SuperMix online help file, the SuperMix user's guide, the SuperMix 
website, technical support and other information.  
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The five options on the Help menu shown above are discussed in the following 
sections. 

 
The Contents option 

The Contents option on the Help menu is used to open the SuperMix online help file. 
Click on the Contents option to open the following help window for the SuperMix 
online help file. 

 

 
 

Use the menus or buttons or click on one of the links to browse the different 
sections of the SuperMix online help file. 

 
The User's Guide option 

The User's Guide option on the Help menu provides access to the PDF copy of the 
SuperMix user's guide. Adobe Reader (which can be downloaded for free from 
Adobe's website) is needed to open a PDF file. A click on the User's Guide option 
opens the following Adobe Reader window. 
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The Important Links option 

The Important Links option on the Help menu provides access to the online resources 
of SuperMix. 
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Select an option from the pop-up menu above to open the corresponding web page 
with your default internet browser. 

 
The Technical Support option 

The Technical Support option provides information about obtaining assistance in 
troubleshooting problems encountered with SuperMix.  

 

 
 

The Close button is used to return to the current SuperMix window. The System Info 
button provides complete details of the computer used to run SuperMix. This 
information can be useful to address technical support issues.  

 
The About SuperMix option 

Use the About SuperMix option to obtain general information about SuperMix.  
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Click on the Close button to return to the current SuperMix window. 

 

2.2 The spreadsheet window 
The SuperMix spreadsheet window is used to display a new or existing SuperMix data 
file. The menus on the spreadsheet window can be used to manipulate the data 
entries in an existing SuperMix data file. It is also used to access the Model Setup 
window, which is used to specify a mixed-effects model and to edit existing 
SuperMix model files. These menus can also be used to create new or open existing 
SuperMix graph files. In Section 2.5 some basic spreadsheet operations are 
illustrated. In the sections to follow, we review the four menus of the SuperMix 
spreadsheet window. 

2.2.1 The File menu 

The options on the File menu of the spreadsheet window are used to open a new 
SuperMix project, open an existing ss3 file, create a new SuperMix model (.mum) file, 
edit an existing model file, or convert an existing MIX definition file to a SuperMix 
model file. It is also used to create or edit a SuperMix graph file. An example of the 
File menu is shown below. 
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When an ss3 file as well as a SuperMix model file are opened, the File menu changes 
as shown in the following window. 

 

 
 

The New Project option 

The New Project option is used to open an independent SuperMix main window. 
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The Exit option 

The Exit option is used to close the current open SuperMix main window. 

 
The New Model Setup option 

The New Model Setup option of the spreadsheet window provides access to the 
Configuration, Variables, Starting Values, Patterns, Advanced and Linear Transforms 
screens of the Model Setup window  shown below. Each screen is opened by 
clicking on the corresponding tab.  

 

 
 

These screens are used to specify a mixed-effects model to be fitted to the data in 
the open spreadsheet window. The appearance of the screens depends on the type of 
outcome (dependent) variable (continuous, count, ordered, or nominal) that is 
selected on the Configuration screen shown above. A detailed description of each of 
these screens is given in Section 2.4. Once a model is defined, it can be saved as a 
.mum file. 
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The Open Existing Model Setup option 

The Open Existing Model Setup option is used to open the Model Setup window of 
an existing SuperMix model file. This is accomplished by clicking on the Open 
Existing Model Setup option, which loads the following Open Mixed Up Model dialog 
box. 

 

Browse for the desired SuperMix model file, select it, and click on the Open button to 
load the Model Setup window for the selected SuperMix model file. 

 

 
 

The Convert MIX Definition File option 

The Convert MIX Definition File option is used to convert a MIX definition file, which 
has the default extension .def, to a SuperMix model file. Selecting this option loads 
the following Open Import Definition File dialog box. 
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Next, browse for the desired MIX definition file, select it, and click on the Open 
button to load the Model Setup window for the SuperMix model file created from the 
selected MIX definition file. 

 
The Data-based Graphs pop-up menu 

The Data-based Graphs pop-up menu is used to create a new SuperMix graph from 
the data displayed in the open ss3 file in a SuperMix graph window. The menus and 
dialogs of the SuperMix graph window for new and existing SuperMix graphs are 
reviewed in Chapter XXX.  
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The options listed below are discussed in detail in Chapter XXX, which contains 
examples of all the plots that SuperMix can produce. 

 

o The Exploratory option is used to produce single or overlay color-coded Y 
against X plots. Groups of plots are obtained by using a filter variable. A 
typical example is given in Section 3.2. 

o The Univariate option on the Data-based Graphs pop-up menu is used to 
create a bar chart, a pie chart or a histogram for the data displayed in the 
spreadsheet window.  

o The Bivariate option on the Data-based Graphs pop-up menu is used to 
create a scatter plot, a line plot, a combination line and scatter plot, a box-
and-whisker plot, or a 3-dimensional bar chart for the data in the open 
SuperMix data file.  

o The Multivariate option on the Data-based Graphs pop-up menu is used to 
make a matrix scatter plot based on the data in the open ss3 file. This 
provides an organized way of simultaneously looking at a set of bivariate 
plots. 
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The Model-based Graphs pop-up menu 

The options on the Model-based Graphs pop-up menu are activated when a model 
setup file is opened. These options are used to create a new SuperMix graph from the 
data displayed in the open spreadsheet window. The menus and dialogs of the 
SuperMix graph window for new and existing SuperMix graphs are reviewed in 
Chapter XXX.  

 

 
 

Available options are: 

o The Equations option on the Model-based Graphs pop-up menu loads the 
Plot Equations for dialog box which can be used to plot model equations of 
an outcome variable for given values of the predictors in the model. 

o The Residuals option on the Model-based Graphs pop-up menu provides 
access to the Plot of Residuals dialog box, which is used to create a residual 
plot for the residuals based on the current SuperMix analysis.  

o The Confidence Intervals option is used to open the 95% C.I. for Level-1 
Variables dialog box, which is used to create confidence interval plots.  
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The Open Graph option 

The Open Graph option is used to open an existing SuperMix graph file with a default 
extension .mug. You first click on the Open Graph option to load the following 
Open Mixed Up Graph dialog box. 

 

 
 

The next steps are to browse for the desired SuperMix graph file, select it, and click 
on the Open button to open the graph window for the selected SuperMix graph file. 

 
The Save option 

The Save option on the File menu is used to save any changes made to the data or 
the model setup file (mum). Please note that any change to the data will not be 
saved to file unless you use this option or the Save As option.  

 
The Save As option 

The Save As option on the File menu is used to save the opened ss3 file or mum file 
as another SuperMix data file or mum file. To save the spreadsheet data as another 
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file, select the Save As option to load the following Save As Spreadsheet Data 
dialog box.  

 

 
 

Enter the file name in the File name string field and click on the Save button to save 
the SuperMix data file. 

2.2.2 The Edit menu 

The options on the Edit menu of the SuperMix spreadsheet window are used to edit 
the data entries of the open SuperMix data file. To use these options, select the data 
to be edited (cell(s), row(s) or columns(s)). Then click on the Edit menu to produce 
the following window. 
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The next step is to select one of the options available, which have the following 
effects on the selected data. 

 

o The Cut option cuts the data selection from the spreadsheet window and 
places it into the Windows clipboard. 

o The Copy option places the data selection in the Windows clipboard. 
o The Paste option pastes data from the Windows clipboard into the selected 

area of the spreadsheet window. 
o The Paste (value only) option pastes only the actual values (ignoring the 

formats) of the data from the Windows clipboard into the selected area of the 
spreadsheet window. 

o The Clear option replaces the selected data with empty cell(s). Choosing this 
option activates the following drop-down menu. 

 

 
 

 The Clear All option deletes the values and the formulas of the selected 
data.  



                                                                                                                                                  
21                                                                                      
 

 

 

 The Clear Data option deletes the values of the data selection, but leaves 
the corresponding formulas intact.  

 The Clear Formula option deletes the formulas of the selected data, but 
not the corresponding values. 

o The Create Header from Row creates spreadsheet headers that correspond to 
the labels in the selected row. 

 

2.2.3 The Window menu 

The Window menu is used to toggle between open spreadsheet windows. 

2.2.4 The Help menu 

The Help menu of the spreadsheet window is identical to that of the main window 
and is reviewed in Section 2.1.2. 

 

2.3 The graph window 
The SuperMix graph window is opened by creating a new SuperMix graph or by 
opening an existing SuperMix graph file. We accomplish this by using one of the 
options on the Data-based Graphs pop-up menu or the Open Graph option or one of 
the options on the Model-based Graphs pop-up menu (if a SuperMix model file is 
also open) on the File menu of the spreadsheet window reviewed in Section 2.2.1. 
The menus and dialogs of the SuperMix graph window are reviewed and illustrated 
in Chapter xxx.  

2.4 The Model Setup window 
A SuperMix mum file (model setup file) is always associated with an ss3 file (data 
spreadsheet file). This ensures that variable selections are maintained correctly in 
the mum file, regardless of changes to the header text and cut/paste/move operations 
on the columns of the ss3 file. For this reason, the Model Setup window is accessed 
via the File menu of the spreadsheet window. This is done by selecting the New 
Model Setup or Open Existing Model Setup options. The Model Setup window has 
six tabs. By clicking on a tab, the corresponding Configuration, Variables, Starting 
Values, Patterns, Advanced, or Linear Transforms screen is accessed. The 
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appearance of a screen depends on the type of outcome variable selected. The 
purpose of a field is displayed at the bottom of the screen when the field is clicked. 
Tables 2.1 to 2.13 are summaries of these descriptions.  

2.4.1 The Configuration screen 

The Configuration screen is used to provide a title for the analysis, to select the type 
and name of the outcome (dependent) variable, and to indicate identifiers of the 
level-2 and level-3 units. Additionally, it contains options that control the amount of 
information to be saved to file and the parameters of the optimization procedure. 
When the New Model Setup or Open Existing Model Setup options on the File menu 
are used, the Configuration screen is, by default, the first screen displayed. 

 

The same Configuration screen is used for continuous and count outcomes, but its 
contents change when the dependent variable type is ordinal or nominal. The screen 
is the same for ordinal and nominal outcome types. The two cases are discussed 
separately below. 

 
Configuration screen for continuous and count outcomes 

An example of the Configuration screen of the Model Setup window for a 
continuous response variable is shown below. The layout is identical when the 
dependent variable type is changed from continuous to count (see Section 3.4 for an 
example based on a count outcome variable). 
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The 14 possible entries on the Configuration screen of the Model Setup window for 
continuous or count response variables are summarized in Table 2.1. 

 

1 

2 

3 

4 

5 

6 

7 

8 

9 

10 

11 

12 

13 

14 
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Table 2.1: Entries on the Configuration screen of the Model Setup window for continuous 
and count outcomes 

 

Number Caption Purpose Type Action Options 

1 Title 1 
To specify the first line 
of the title to be listed in 
the output file. 

Text box 
Enter a string of not 
more than 60 
characters.  

  

2 Title 2 
To specify the second 
line of the title to be 
listed in the output file. 

Text box 
Enter a string of not 
more than 60 
characters. 

  

continuous 
(default) 

ordered 

nominal 

3 
Dependent 
Variable Type 

To specify the variable 
type for the response 
variable. 

Drop-
down list 
box 

Select an option 
from the drop-down 
list box. 

count 

4 Level-2 IDs 

To specify the variable 
that defines the second 
level of the hierarchy in 
the data. 

Drop-
down list 
box 

Select a variable 
from the drop-down 
list box. 

  

5 
Dependent 
Variable 

To specify the response 
variable of the model. 

Drop-
down list 
box 

Select a variable 
from the drop-down 
list box. 

  

6 Level-3 IDs 

To specify the variable 
that defines the 3rd level 
of the hierarchy in the 
data. 

Drop-
down list 
box 

Select a variable 
from the drop-down 
list box. 

  

no (default) 

means only 7 
Write Bayes 
Estimates 

To request a text file for 
the Bayes estimates. 

Drop-
down list 
box 

Select an option 
from the drop-down 
list box. means & 

(co)variances 

8 
Convergence 
Criterion 

To specify the 
convergence criterion 
for the iterative 
algorithm. 

Text box 

Enter a non-zero 
positive real number 
if the default of 
0.0001 is not 
desired. 
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Table 2.1: Entries on the Configuration screen of the Model Setup window for continuous 
and count outcomes (continued) 

 

9 
Number of 
Iterations 

To specify the maximum 
number of iterations for 
the iterative algorithm. 

Text box 
Enter a positive 
integer if the default 
of 100 is not desired. 

  

false (default) 
10 

Missing Values 
Present 

To specify the missing 
value status of the data. 

Drop-
down list 
box 

Select an option 
from the drop-down 
list box. true 

no (default) 
11 

Generate Table 
of Means 

To request the printing 
of a table as part of the 
output. 

Drop-
down list 
box 

Select an option from 
the drop-down list 
box. yes 

12 Means Variable 

To specify the variable 
for which the tables 
should be created (see 
8). 

Drop-
down list 
box 

Select a variable 
from the drop-down 
list box. 

  

13 
Missing Value 
for the 
Dependent Var 

To specify the missing 
value code for the 
response variable. 

Text box Enter a real number.   

14 
Global Missing 
Value 

To specify the global 
missing value code. 

Text box Enter a real number.   

 
Configuration screen for ordered, nominal and binary outcomes 

The following screen is an example of the Configuration screen of the Model Setup 
window  in the case of an ordered response variable. An example of this screen for a 
nominal outcome variable is given in Section 3.5. 

 

As shown in the image below, the 5 entries shown in bold typeface are either new or 
different compared with those on the Configuration screen of the Model Setup 
window for continuous or count outcome variables. These 5 entries are summarized 
in Table 2.2. Please refer to Table 2.1 for the information about all the other entries. 
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Table 2.2: Entries of the configuration screen for ordered and nominal outcomes 

 
Number Caption Purpose Type Action Options 

continuous 
(default) 

ordered 

nominal 

3 
Dependent 
Variable Type 

To specify the variable type 
for the response variable. 

Drop-
down list 
box 

Select an option 
from the drop-down 
list box. 

count 

5 
Dependent 
Variable 

To specify the response 
variable of the model. 

Drop-
down list 
box 

Select a variable 
from the drop-down 
list box. 

  

15 Categories 

To show the value of each 
category of the ordered 
dependent variable selected 
in 5. 

Grid box     

1 

2 

3 

4 

5 

6 

7 

8 

9 
15 

16 

17 

13 

14 

10 
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Table 2.2: Entries of the configuration screen for ordered and nominal outcomes 
(continued) 

 
no (default) 

16 
Perform 
Crosstabulation 

To specify a cross tabulation 
of selected variable by the 
outcome variable. 

Drop-
down list 
box 

Select an option 
from the drop-down 
list box. yes 

17 
Crosstab 
Variable 

To specify the variable to be 
crosstabulated with the 
outcome variable (see 8). 

Drop-
down list 
box 

Select a variable 
from the drop-down 
list box. 

  

 

2.4.2 The Variables screen 

Besides the variables screen for the ordered outcome, which doesn’t include the 
option to select an intercept as an explanatory variable, this screen has the same 
appearance for all outcome types and is used to select explanatory variables and 
random effects. The unknown model parameters are the coefficients of the 
explanatory variables and the variances and covariances of the random effects. The 
appearance of the Variables screen depends on the number of levels of the model. 
For a two-level model, the 3 columns in the Available grid and the L-3 grid will be 
hidden. By default, an intercept term is included in the fixed part (explanatory 
variables) and in the random part (random effects) of the model. 

 

The following screen is an example of the Variables screen of the Model Setup 
window that is used for variable selection for continuous, count, or nominal 
response variables. The 9 possible entries of the Variables screen of the Model Setup 
window for continuous, count, or nominal response variables are summarized in 
Table 2.3. 
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1a 

2a 

3a 

2b 

1b 

5 

3b 

6 

4 
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Table 2.3: Entries of the Variables screen 

 

Number Caption Purpose Type Action Options 

a E  
To specify the 
explanatory variable(s) 
of the model. 

Column of 
check box(es) 

Check the E 
column(s) of the 
variable(s). 

  
1 

b 
Explanatory 
Variables 

Displays the variable(s) 
selected in 1a. 

Grid box     

a 2 
To specify the level-2 
random effects of the 
model. 

Column of 
check box(es) 

Check the 2 
column(s) of the 
variable(s). 

  
2 

b 
L-2 Random 
Effects 

Displays the variable(s) 
selected in 2a. 

Grid box     

a 3 
To specify the level-3 
random effects of the 
model. 

Column of 
check box(es) 

Check the 3 
column(s) of the 
variable(s). 

  
3 

b 
L-3 Random 
Effects 

Displays the variable(s) 
selected in 3a. 

Grid box     

Check (default) 
4 Include Intercept 

To specify an intercept 
term for the fixed part of 
the model. 

Check box 
Uncheck the check 
box if an intercept is 
not desired. Uncheck 

Check (default) 

5 Include Intercept 
To specify a random 
intercept at level-2 of 
the model. 

Check box 

Uncheck the check 
box if a level-2 
random intercept is 
not desired. 

Uncheck 

Check (default) 

6 Include Intercept 
To specify a random 
intercept at level-3 of 
the model. 

Check box 

Uncheck the check 
box if a level-3 
random intercept is 
not desired. 

Uncheck 
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2.4.3 The Starting Values screen 

The unknown parameters in a mixed-effects model cannot, in general, be obtained 
as a closed-form expression. To estimate these parameters, use is made of an 
iterative procedure based on the method of maximum likelihood. For count, ordinal, 
and nominal outcomes, the likelihood function is approximated by numerical 
integration. For more than one random effect, this procedure is computationally 
intensive. All iterative procedures start with initial estimates of the values of the 
unknown parameters and, at each iteration, the algorithm attempts to improve this 
estimate until convergence is obtained. The closer these initial estimates (the 
starting values) are to the maximum likelihood solution, the fewer iterations are 
needed to obtain convergence and reach the final solution.  

 

SuperMix automatically generates starting values for the model parameters and 
typically these values are sufficient to ensure convergence. There may, however, be 
cases where a model with many parameters takes a long time to run, and if small 
modifications are made to such a model, one can use the parameter estimates from 
the previous analysis as starting values for the next analysis. Alternatively, one may 
want to fix some of the parameter values at specific values, for example, the slope 
coefficient of variable X at 0.1. This can be accomplished by selecting the user-
defined option and entering this value for X. Note that the value of 0.1 will remain 
fixed during the optimization procedure if it is specified as fixed for X on the 
Patterns screen discussed in Section 2.4.4. 

 
Starting Values screen for continuous or count outcomes 

An example of the Starting Values screen of the Model Setup window for a 
continuous or count response variable is shown below.  
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An example of the Starting Values screen of the Model Setup window for continuous 
or count outcomes is shown above. The 5 possible entries of the Starting Values 
screen of the Model Setup window for count or nominal response variables are 
summarized in Table 2.4. 

 

1 

2 

5 

4 

3 
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Table 2.4: Entries of the Starting Values screen for continuous and count outcomes 

 
Number Caption Purpose Type Action Options 

automatic (default) 
1 Starting Values 

To specify the type of 
starting values to be 
used. 

Drop-
down list 
box 

Select an option from 
the drop-down list 
box. user-defined 

2 
Starting Error 
Variance 

To specify the starting 
error variances. 

Text box 
Enter a integer if the 
default of 1 is not 
desired. 

  

3 
Explanatory 
Variables 

To specify the starting 
value(s) for the 
coefficients of 
explanatory variable(s) 
of the fixed part of the 
model. 

Grid box 

Enter a real number in 
the corresponding 
Value box(es) of the 
variable(s) of interest. 

  

4 
Level 2 
(Co)variances 
Starting Values 

To specify the starting 
value(s) for the 
variance(s) and/or 
covariance(s) of the 
level-2 random effects. 

Grid box 

Enter a real number 
(positive for 
variances) in the 
corresponding Value 
box(es) of the 
variable(s) of interest. 

  

5 
Level 3 
(Co)variances 
Starting Values 

To specify the starting 
value(s) for the 
variance(s) or 
covariance(s) of the 
level-3 random effects. 

Grid box 

Enter a real number 
(positive for 
variances) in the 
corresponding Value 
box(es) of the 
variable(s) of interest. 

  

 
Starting Values screen for ordered outcomes 

For ordinal outcomes, additional grid boxes appear to allow for user-specified 
starting values of thresholds and threshold-explanatory variable(s) interaction(s). 
The following screen is an example of the Starting Values screen of the Model Setup 
window. 

 

As shown in the image below, the single entry shown in bold typeface is different 
from those of  the Starting Values screen of the Model Setup window for continuous 
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or count outcome variables. This entry is described in Table 2.5. Please refer to 
Table 2.4 for the information about all the other entries.  

 

 
 

Table 2.5: Entry of the Starting Values screen for ordered outcomes 

 
Number Caption Purpose Type Action 

6 
Starting Values 
for Thresholds 

Enter the starting values 
for the thresholds. 

Grid box 

Enter real numbers. 
The values must be 
monotonically 
increasing. 

7 
Starting Values 
for threshold 
interactions 

Enter the starting values 
for the threshold 
interaction terms. 

Grid box 

Enter a real number in 
each of the 
corresponding Value 
box(es) of the 
variable(s) of interest. 

 

6 

1 

5 

4 

3 

7 
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Starting Values screen for nominal or binary outcomes 

When the nominal outcome is selected, the grid boxes appear differently with a slide 
bar as shown below. 

 

 
 

The 3 different entries shown in bold typeface are either new or different compared 
with those on the Starting Values screen of the Model Setup window for continuous 
or count outcome variables. These 4 entries are summarized in Table 2.6. Please 
refer to Table 2.4 for the information about all the other entries. 

 

1 

5 

4 

3 
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Table 2.6: Entries of the Starting Values screen for nominal outcomes 

 
Number Caption Purpose Type Action 

3 
Explanatory 
Variables 

To specify the starting 
value(s) for the 
coefficients of 
explanatory variable(s) of 
the fixed part of the 
model. 

Grid box 
with slide 
bar 

Enter a real number in 
the corresponding 
Value box(es) of the 
variable(s) of interest. 

4 
Level 2 
(Co)variances 
Starting Values 

To specify the starting 
value(s) for the 
variance(s) and/or 
covariance(s) of the 
level-2 random effects. 

Grid box 
with slide 
bar 

Enter a real number 
(positive for 
variances) in the 
corresponding Value 
box(es) of the 
variable(s) of interest. 

5 
Level 3 
(Co)variances 
Starting Values 

To specify the starting 
value(s) for the 
variance(s) or 
covariance(s) of the 
level-3 random effects. 

Grid box 
with slide 
bar 

Enter a real number 
(positive for 
variances) in the 
corresponding Value 
box(es) of the 
variable(s) of interest. 

 

2.4.4 The Patterns screen 

This screen is used to specify patterns or structures for the coefficients of the 
explanatory variables and variances and covariances of the random effects. A 
typical Patterns screen is shown below. Note that the default numbers for these 
patterns (1, 2, 3, …) are dependent on the number of parameters listed in a grid. The 
default numbers indicate that all parameters are set free. On the other hand, if a 
number is replaced by a '0', the corresponding parameter is fixed to the default or 
user-specified value on the Starting Values screen. 
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Patterns screen for continuous, ordered, nominal and count  outcomes 

The 6 different entries of the Patterns screen of the Model Setup window for 
continuous, ordered,  nominal, or count response variables are summarized in Table 
2.7. For an ordinal outcome variable, provision is also made for entering user-
defined values for threshold parameters. 

 

 
 

1a 

2a 

3b 

2b 

1b 

3a 
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Table 2.7: Entries of the Patterns screen for continuous, count and nominal outcomes 

 
Number Caption Purpose Type Action Options 

free (default) 

a 

To specify the pattern 
type for the coefficients 
in the fixed part of the 
model. 

Drop-down 
list box 

Select an option 
from the drop-
down list box. user-defined 

1 

b 

Explanatory 
Variables To specify the pattern 

for the covariance 
matrix of the fixed part 
of the model. 

Text box 
Enter integer values 
>= 0 

  

correlated 
(default) 

independent 

unidimensional 

a 

To specify the pattern 
type for the covariance 
matrix of the level-2 
random effects. 

Drop-down 
list box 

Select an option 
from the drop-
down list box. 

user-defined 2 

b 

Level-2 
(Co)variance 
Patterns 

To specify the pattern 
for the covariance 
matrix of the level-2 
random effects. 

Text box 
Enter integer values 
>= 0 

  

correlated 
(default) 

independent 

unidimensional 

a 

To specify the pattern 
type for the covariance 
matrix of the level-3 
random effects. 

Drop-down 
list box 

Select an option 
from the drop-
down list box. 

user-defined 3 

b 

Level-3 
(Co)variance 
Patterns 

To specify the pattern 
for the covariance 
matrix of the level-3 
random effects. 

Text box 
Enter integer values 
>= 0 

  

 
Examples of Patterns: 
 

o The pattern below is used to constrain the coefficients of Treatment 1 and 
Treatment 2 to be equal. Likewise, the coefficients of Treatment 3 and 
Treatment 4 are constrained to be equal.  
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Explanatory Variables Pattern 

Treatment 1 1 
Treatment 2  1 
Treatment 3 3 
Treatment 4  3 

 

Note that a number cannot be larger than the row number on the grid. For 
example, the following pattern is not recognized by SuperMix: 

 
Explanatory Variables Pattern 

Treatment 1 2 
Treatment 2  2 
Treatment 3 4 
Treatment 4  4 

 

o The table below shows three possible patterns for the level-2 variances and 
covariances of the random effects Time1, Time2, Time3, and Time4. 

 
Level-3 co(variance) Pattern 1 Pattern 2 Pattern 3 

Variance, Time1 1 1 1 
Time1, Time2 2 2 2 
Variance, Time2 1 3 3 
Time1, Time3 2 0 0 
Time2, Time3 2 2 0 
Variance, Time3 1 6 6 
Time1, Time4 2 0 0 
Time2, Time4 2 0 0 
Time3, Time4 2 2 9 
Variance, Time4 1 10 10 

 

Pattern 1 restricts all the variances to be equal and, likewise, all the covariances to 
be equal. Pattern 2 specifies that all variances should be estimated freely, all 
covariances one time unit apart are set equal, and all covariances more than one 
time unit apart are fixed at the values specified on the Starting Values screen, the 
default for covariances being zero. Pattern 3 specifies that Time1 and Time2 are 



                                                                                                                                                  
39                                                                                      
 

 

 

correlated, but uncorrelated with Time3 and Time4, which are correlated with each 
other. 

2.4.5 The Advanced screen 

The appearance of the Advanced screen depends on the type of outcome variable 
selected on the Configuration screen, and is used to change default settings used in 
SuperMix. Specific examples of the use of this screen are given in Section 3.4 to 3.7. 
Screens for the various outcome types are given next. 

 
Advanced screen for continuous outcomes – normal distribution 

In repeated measurement studies, the assumption of uncorrelated identically 
distributed level-1 error terms is often unrealistic. The options on the Advanced 
screen shown below allow for correlated level-1 error terms that follow a time series 
process. 

 

 

1 

2 

3a 

3b 

4 

5 

6 

7 

8 

9 
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The 9 different entries of the Advanced screen of the Model Setup window for 
continuous response variables are summarized in Table 2.8. 

 

Table 2.8(a): Entries of the Advanced screen for continuous outcomes with normal 
distribution 

 
Number Caption Purpose Type Action Options 

no AC terms (default) 

fixed AC terms 1 Autocorrelation 
To specify the type of 
autocorrelation terms. 

Drop-
down list 
box 

Select an option 
from the drop-down 
list box. estimate all 

Stationary AR1 
(default) 

Non-stationary AR1 

Stationary MA1 

Stationary 
ARMA(1,1) 

2 Error Form 
To specify a time series 
model for the auto-
correlated errors. 

Drop-
down list 
box 

Select an option 
from the drop-down 
list box. 

General Auto-
correlation 

a 
Autocorrelation 
Terms 

To specify the number 
of autocorrelation 
terms. 

Text box 
Enter an integer if 
the default 1 is not 
desired. 

  

3 

b 
Autocorrelation 
Starting Values 

To specify the starting 
value(s) for the 
autocorrelation(s). 

Grid box 
Enter a real number 
in the region of  

[-0.99, 0.99]. 
  

equal (default) 

4 Unit Weighting 

To select equal or 
differential weighting 
for the unites for 
continuous dependent 
variable. 

Drop-
down list 
box 

Select an option 
from the drop-down 
list box. differential 

5 Level-1 Weight 

To specify the weight 
variable that defines the 
first level of the 
hierarchy in the data. 

Drop-
down list 
box 

Select a variable 
from the drop-down 
list box. 
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Table 2.8(a): Entries of the Advanced screen for continuous outcomes with normal 
distribution (continued) 

 

6 Level-2 Weight 

To specify the weight 
variable that defines the 
second level of the 
hierarchy in the data. 

Drop-
down list 
box 

Select a variable 
from the drop-down 
list box. 

  

7 Level-3 Weight 

To specify the weight 
variable that defines 
level-3 of the hierarchy 
in the data. 

Drop-
down list 
box 

Select a variable 
from the drop-down 
list box. 

  

normal (default) 

gamma 8 
Distribution 
Model 

To select an appropriate 
distribution model. 

Drop-
down list 
box 

Select a distribution 
from the drop-down 
list. inverse Gaussian 

9 'Time' Variable 
To specify the time 
variable. 

Drop-
down list 
box 

Select a variable 
from the drop-down 
list box. 

  

 
Advanced screen for continuous outcomes – gamma/inverse Gaussian 
distribution 

When the gamma or inverse Gaussian distribution is selected, the Advanced screen 
is a little different from when the normal distribution is selected as shown below. 
The 4 different entries of the Advanced screen of the Model Setup window for 
continuous response variables are summarized in Table 2.8. 
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Table 2.8(b): Entries of the Advanced screen for continuous outcomes with 
gamma/inverse Gaussian distribution 

 
Number Caption Purpose Type Action Options 

normal (default) 

gamma 8 
Distribution 
Model 

To select an 
appropriate 
distribution model. 

Drop-
down list 
box 

Select a distribution 
from the drop-down 
list. inverse Gaussian 

none (default) 

deviance 9 Estimate Scale 
To specify the method 
for estimating the 
scale. 

Drop-
down list 
box 

Select an estimated 
scale from the drop-
down list box. Pearson 

maximum posterior 

Adaptive quadrature 10 
Optimization 
Method 

To select the 
optimization method. 

Drop-
down list 
box 

Select an 
optimization method 
from the drop-down 
list box. 

non-adaptive 
quadrature (default) 

4 

5 

6 

7 

8 

9 

10 

11 
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Table 2.8(b): Entries of the Advanced screen for continuous outcomes with 
gamma/inverse Gaussian distribution (continued) 

 

11 
Number of 
Quadrature 
Points 

To enter the 
quadrature points (per 
random-effect 
dimension) to use in 
the numerical 
integration. 

Text box 

Enter an integer if the 
default 10 is not 
desired. It is usually 
set to 10 for 1 effect 
and 5 to 10 for 2 or 3 
effects. 

  

 
Advanced screen for ordered outcomes 

An important feature of mixed-effects models with ordered outcomes is the 
inclusion of threshold parameters in the model. As illustrated in Section 3.6, the 
number of threshold parameters equals 2C  , where C  is the number of distinct 
categories of the outcome variable. If right-censoring (see Section 3.7) is included in 
the model specification, the number of thresholds becomes 1C   and a Censor 
Variable is selected. The mixed-effects model for ordinal outcomes additionally 
allows for the inclusion of Explanatory Variable-threshold interaction terms. If entry 
number 10 in the screen below is set equal to 2, for example, then interaction terms 
of the first two explanatory variables with each of the thresholds are included in the 
model. One can also select a weight variable, link function (Function model) and the 
number of quadrature points to be used for the approximation of the likelihood 
function by numerical integration. 

 

Table 2.9 gives a summary of the 12 possible entries of the Advanced screen of the 
Model Setup window for an ordered response variable. 
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As shown in the above image, the 6 entries shown in bold typeface are either new or 
different compared with those on the Advanced screen of the Model Setup window 
for continuous outcome variables. These 6 entries are summarized in Table 2.9 
Please refer to Table 2.8(a) and (b) for the information about all the other entries. 

 

1a 

1b 

1c 

4 

5 
6 

10 

12 

9 

11 

7 

8 

2a 

2b 

3 
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Table 2.9: Entries of the Advanced screen for ordered outcomes 

 

Number Caption Purpose Type Action Options 

no (default) 

a 
Include 
Interactions 

To indicate if explanatory 
variable interactions 
should be include in the 
model. 

Drop-
down list 
box 

Select an option 
from the drop-down 
list box. yes 

b 
Number of 
Interactions 

To specify the number of 
interactions. 

Text box 

Enter an integer if 
the default maximum 
allowable value is 
not desired. 

  

scaling terms  

1 

c 
Type of 
Extension 

To select whether to treat 
the explanatory variables 
as having scaling effects 
or threshold interactions. 

Drop-
down list 
box 

Select an option 
from the drop-down 
list box. 

threshold 
interactions 
(default) 

none (default) 
a 

Right-
Censoring 

To specify is right-
censoring is included. 

Drop-
down list 
box 

Select an option 
from the drop-down 
list box. include 

2 

b 
Censor 
Variable 

To specify the censor 
variable. 

Drop-
down list 
box 

Select a variable 
from the drop-down 
list box. 

  

subtract means 
( ã - X â ) (default) 

3 Model Terms 
To select subtracting or 
adding the model terms to 
the threshold. 

Drop-
down list 
box 

Select an option 
from the drop-down 
list box. add, means 

( ã X â ) 

no (default) 
8 

Level-2 
Random 
Thresholds 

To specify if there are 
thresholds for the level-2 
random effects. 

Drop-
down list 
box 

Select an option 
from the drop-down 
list box. yes 

no (default) 
9 

Level-3 
Random 
Thresholds 

To specify if there are 
thresholds for the level-3 
random effects. 

Drop-
down list 
box 

Select an option 
from the drop-down 
list box. yes 

12 
Function 
Model 

To specify the link 
function. 

Drop-
down list 
box 

Select an option 
from the drop-down 
list box. 

probit (default), 

logistic,  

complementary log-
log, log-log 
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Advanced screen for nominal outcomes 

The general settings of this screen is similar to the one used for the continuous and 
ordinal variables, but nominal dependent variable settings is different as shown in 
the bold entry number 1 below. 

 

 
Table 2.10: Entries of the Advanced screen for nominal outcomes 

 
Number Caption Purpose Type Action Options 

first (default) 

1 
Reference 
Category 

To select whether the 
first or last category of 
the outcome should be 
used as the reference 
category. 

Drop-
down list 
box 

Select a reference 
category from the 
drop-down list. last 

 

Note that all the information for the other 6 entries are given in Table 2.8(a) and (b). 

4 

5 

6 

10 

11 

7 

1 
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Advanced screen for count outcomes with Poisson distribution 

The screen below has the same functionality as the screen used for nominal 
outcomes, except that provision is made here for the specification of an Offset 
Variable. In practice, it can occur that the coefficient of some covariate is assumed to 
be unity. This covariate is commonly known as an offset variable. Offsets are 
typically used when the response variable is a rate rather than a number or count. 

 

The 2 entries pertaining to the offset variable on the Advanced screen of the Model 
Setup window for a count outcome are summarized in Table 2.11. Note that entries 
in the Advanced screen for the count outcome variable are similar to those for the 
ordered outcome. The information for the other 2 entries are given in Table 2.9. 

 

 
 

1a 

1b 

4 

5 
6 

10 

11 

7 

2 

3 
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Table 2.11(a): Entries of the Advanced screen for count outcomes with Poisson 
distribution 

 
Number Caption Purpose Type Action Options 

no (default) 
a 

Incorporate 
Time Offset 

To select whether or not 
to include an offset 
variable. 

Drop-
down list 
box 

Select an option from 
the drop-down list 
box. yes 

1 

b 
Offset 
Variable 

To specify the offset 
variable. 

Drop-
down list 
box 

Select a variable from 
the drop-down list 
box. 

  

Poisson (default) 
2 

Distribution 
Model 

To select an appropriate 
distribution model. 

Drop-
down list 
box. 

Select a distribution 
from the drop-down 
list box. negative binomial 

none (default) 

deviance 3 Estimate Scale 
To specify the method for 
estimating the scale. 

Drop-
down list 
box 

Select an estimated 
scale from the drop-
down list box. Pearson 

 
Advanced screen for count outcomes with negative binomial distribution 

When the negative binomial distribution is selected, the Advanced screen of the 
count variable is slightly different as shown below. 
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As shown above, the bold font entries 1 and 2 are different from the previous 
screen. 

 

Table 2.11(b): Entries of the Advanced screen for count outcomes with negative binomial 
distribution 

 
Number Caption Purpose Type Action Options 

Poisson (default) 
1 

Distribution 
Model 

To select an appropriate 
distribution model. 

Drop-
down list 
box. 

Select a distribution 
from the drop-down 
list box. negative binomial 

2 
Dispersion 
Parameter 

To enter the dispersion 
parameter for the negative 
binomial model. 

Text box 

Enter any numeric 
value greater than 
0.0. The default value 
is 1.0. 

 

 

4 

5 

6 

10 

11 

7 

1 

2 
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Advanced screen for binary outcomes 

When the negative binomial distribution is selected, the Advanced screen of the 
count variable is slightly different as shown below. 

 

 
 

As shown above, the bold font entries 1 and 2 are different from the previous 
screen. 

 

4 

5 
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10 

11 

7 

2 

1b 
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1a 
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Table 2.12: Entries of the Advanced screen for binary outcomes 

 
Number Caption Purpose Type Action Options 

Bernoulli (default) 
a 

Distribution 
Model 

To select an appropriate 
distribution model. 

Drop-
down list 
box. 

Select a distribution 
from the drop-down 
list box. binomial 

1 

b 
Number of 
Trials 

To select the column of 
the spreadsheet, which 
contains the number of 
trails. 

Drop-
down list 
box 

Select a variable 
from the drop-down 
list box. 

  

probit (default) 

logistic 

complementary log-
log 

2 
Function 
Model 

To select an appropriate 
link function. 

Drop-
down list 
box. 

Select a link function 
from the drop-down 
list box. 

log-log 

none (default) 

deviance 3 Estimate Scale 
To specify the method for 
estimating the scale. 

Drop-
down list 
box 

Select an estimated 
scale from the drop-
down list box. Pearson 

 

2.4.6 The Linear Transforms screen 

Linear transforms are used to test hypotheses of the type 

   

0 1 1 2 2 3 3: ... 0k kH c c c c       

 
where 1 2 3, , ,..., k     are model parameters and 1 2 3, , ,..., kc c c c  user-specified real-

valued coefficients. For each linear transform, a Z -statistic and an associated two-
tailed p -value are saved to the output file. The Z -statistic is a function of the 
estimated parameters and the large sample covariance matrix of the estimates. The 
value of the linear transform when the parameters are replaced with their estimates 
is also of interest. This value also appears in the output. 
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An example of the Linear Transform screen in the case of an ordinal outcome 
variable is given below. Also see Section 3.8 for an additional example. For 
continuous, count and nominal variables the Linear Transform screens are identical, 
but it differ from that for an ordinal outcome in that the screen for an ordinal 
outcome contains threshold parameter information. 

 
Linear Transforms screen for continuous and count outcomes 

The buttons and options on the Linear Transforms screen are shown below. 

 

 
 

A summary of the 3 buttons and 4 different entries of the Linear Transforms screen 
of the Model Setup window for an ordered outcome is given in Table 2.12. 

 

2 

4 

7 

6 

5 

1 

3 
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Table 2.13: Entries of the Linear Transforms screen for continuous and count outcomes 

 
Number Caption Purpose Type Action Options 

1 Add Transform 
To create a new linear transform 
in 4. 

Click 
Button 

Click to add a blank 
transform. 

  

2 Copy Transform 
To create a copy the selected 
transform in 4 with a different 
name. 

Click 
Button 

Click to copy and 
paste the select 
transform. 

  

3 
Remove 
Transform 

To delete the selected transform 
in 4. 

Click 
Button 

Click on the button 
to delete the selected 
transform. 

  

4 
Linear 
Transforms 

To select the linear transform and 
edit it's components. 

Grid box 
Enter string(s) as 
names for 
transforms. 

  

5 
Explanatory 
Variables 

To specify the coefficient(s) for 
the linear transformation(s) of the 
fixed part of the model. 

Grid box Enter real number(s).   

6 
Level-2 Random 
Effect 
(Co)variances 

To specify the coefficient(s) for 
the linear transformation(s) of the 
covariance matrix of the level-2 
random effects. 

Grid box Enter real number(s).   

7 
Level-3 Random 
Effect 
(Co)variances 

To specify the coefficient(s) for 
the linear transformation(s) of the 
covariance matrix of the level-3 
random effects. 

Grid box Enter real number(s).   

 
For example, in the Linear Transforms screen shown below we wish to test the 
hypothesis that 

 

int ercept  + 1Threshold  = 0.   
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Linear Transforms screen for ordered outcomes 

Additional grid boxes appear to allow for user-specified starting values of 
thresholds and threshold-explanatory variable(s) interaction(s) for ordinal outcomes. 
The following screen is an example of the Linear Transforms screen of the Model 
Setup window. 

 

Only the 2 entries shown in bold typeface are either new or different compared with 
those on the Linear Transforms screen of the Model Setup window for continuous or 
count outcome variables. These 2 entries are summarized in Table 2.13. Please refer 
to Table 2.12 for the information about all the other entries. 
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Table 2.14: Entries of the Linear Transforms screen for ordered outcomes 

 
Number Caption Purpose Type Action 

8 Thresholds 

To specify the coefficient(s) 
for the linear 
transformation(s) of the 
thresholds. 

Grid box Enter real number(s). 

9 
Thresholds 
Interactions 

To enter thresholds for the 
selected transform 

Grid box Enter real number(s). 

 

2 

4 

7 

6 

8 

1 

3 

9 
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Linear Transforms screen for nominal and binary outcomes 

Additional slide bar appears for as shown in the following screen is an example of 
the Linear Transforms screen of the Model Setup window. 

 

 
 

Only the 2 entries shown in bold typeface are either new or different compared with 
those on the Linear Transforms screen of the Model Setup window for continuous or 
count outcome variables. These 2 entries are summarized in Table 2.14. Please refer 
to Table 2.12 for the information about all the other entries. 

 

2 

4 

7 

6 

5 

1 

3 
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Table 2.15: Entries of the Linear Transforms screen for nominal outcomes 

 
Number Caption Purpose Type Action 

5 
Explanatory 
Variables 

To specify the coefficient(s) 
for the linear 
transformation(s) of the fixed 
part of the model. 

Grid box 
with 
slide bar 

Enter real number(s). 

6 
Level-2 Random 
Effect 
(Co)variances 

To specify the coefficient(s) 
for the linear 
transformation(s) of the 
covariance matrix of the 
level-2 random effects. 

Grid box 
with 
slide bar 

Enter real number(s). 

7 
Level-3 Random 
Effect 
(Co)variances 

To specify the coefficient(s) 
for the linear 
transformation(s) of the 
covariance matrix of the 
level-3 random effects. 

Grid box 
with 
slide bar 

Enter real number(s). 

 

2.5 Data manipulation 
The SuperMix spreadsheet can be manipulated in various ways. Rows and columns 
can be changed directly, and simple computations or more complex built-in 
functions can be used in individual cells. Some of these manipulations are discussed 
and illustrated in the following sections, using demo.ss3. There are 15 cases 
(patients) in the data set. 

 

 The spreadsheet window for demo.ss3 is opened as follows: 

 

o Use the Open option on the File menu of the main window to load the Open 
Spreadsheet dialog box.  

o Browse for the file demo.ss3 in the Examples folder.  
o Select the file and click on the Open button to open the following SuperMix 

spreadsheet window. 
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The variables include: 

 

o Group is a variable with 3 categories, indicating the group number of the 
patient (5 patients in each group). 

o Age is the age of the patient. 
o WT_kg denotes the weight of the patient in kg. 
o PFat is a measure of percentage body fat. 

 

2.5.1 Basic data manipulations 

It is important to note that any change of the data file will not be saved unless you 
use the Save option on the File menu. 

Cells 

A careful examination of the data shows that the Age entry of the 3rd observation is 
330.00. This is obviously a typing error. Upon further investigation, it turns out that 
the correct age value is 33. To correct this error, select the cell, change the value of 
the formula box from 330.00 to 33.00, and then click on the Apply button. 
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Rows 

To work with a row (or rows) of the data file, click on the row tab(s) to select the 
complete row(s) and then right-click on the selection to display all the options from 
the pop-up menu.  
 

Insert a row 

For example, to insert another row (observation) between the first and the second 
rows, select the second row by clicking on the row 2 tab, right-click on the selected 
row to activate the menu and select the Insert Row option to create the window as 
shown below. 
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An empty row is added to the spreadsheet above the previous second row and the 
total sample size is changed to 16 as shown below. 
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Delete a row 

To delete the empty row that was inserted, select the second row by clicking on the 
row 2 tab. Right click on the selected row and select the Delete Row option to delete 
the second row. 

 

Columns 

To work with a column (or columns) of the data file, first click on the column 
header(s) to select the column(s) and then right-click on one of the selected columns 
to see all the options listed on the pop-up menu.  

 
Insert a column 

To insert another variable between (A)_Group and (B)_Age, first click on the header 
of (B)_Age, right-click on the column to activate the menu and select the Insert 
Column option to create the window as shown below. 

 

 
 

A new column (variable) is added to the spreadsheet. Change the variable name by 
selecting the column header, right-click and select Column Properties to load the 
dialog box as shown below. 
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Input a variable name, such as NewVar, and then click on the OK button to return to 
the spreadsheet window as shown below. 

 

 
 

Delete a column 

To delete the NewVar column that was inserted, select the variable NewVar by 
clicking on the column header. Right-click and select the Delete Column option to 
delete column B. 
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2.5.2 Simple computations 

Assigning values to a new variable 

In demo.ss3, the variable WT_kg is a variable denoting weight in kilograms. We 
would like to use the variable WT_lb, that is, the corresponding weight in pounds. To 
create this variable, first insert a column and change the column header to WT_lb as 
illustrated earlier in Section 2.5.1 to generate the following spreadsheet window. 

 

 
 

Select the column containing the variable WT_lb, input the function 2.20462*(C1) in 
the formula box and click on the Apply button to get the new variable WT_lb as 
shown below. The formula applies to each row of (D)_WT_lb provided that 

 

o this column is selected (highlighted) 

o the first cell of the variable(s) in the formula, in this case C1, is referenced. 
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Save the changes to demo.ss3 by clicking on the Save option on the File menu. 

2.5.3 Built-in functions 

LN function 

In mixed-effects models, we often consider the natural log of a variable. For 
example, the natural log of Age in demo.ss3 may be a more appropriate explanatory 
variable than the original age given in years. The variable LnAge can easily be 
created by using the options available in the SuperMix spreadsheet. 

 

First, create a new column with the header LnAge. Next, select the column 
containing the variable LnAge, input the function LN(B1) in the formula box, and 
click on the Apply button. Each value of the new variable LnAge is the natural log of 
the corresponding values of the variable Age as shown below. 
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SQRT function 

To add another variable, SqrtAge, which is the square root of Age, we proceed as 
follows. As above, first create a new column with the header SqrtAge. 

 

Select the column containing the variable SqrtAge, input the function SQRT(B1) in 
the formula box, and click on the Apply button. Each value of the new variable 
SqrtAge is the square root value of the corresponding value of the variable Age as 
shown below. 
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Save the changes to demo.ss3 by clicking on the Save option on the File menu. 

 

Table 2.16 contains a selection of the built-in functions in SuperMix. A list of values 
can be any of the following types: 

 

o (B1, B2, B3) is the selection of the first three values of the variable in 
column B. 

o (A1:A15) selects all the values of the variable in column A. Starting with the 
first and ending with the one in row 15. 

o (A1:A5, A7, A11:A15)  selects the values of row 1 to row 5, row 7, and row 
11 to row 15 of column A. 

o (A3:A6, B7, D12:D15) contains a list of values from more than one column. 
This selection includes the values of row 3 to row 6 of column A, row 7 of 
column B and row 12 to row 15 of column D. 

 

Table 2.16: Selection of SuperMix functions 

 

Function Definition 

ABS(value) Absolute value 

AVERAGE (list of values) Average 

EXP(value) Exponent base e 

LN(value) Natural log 

LOG(value) Logarithm 

MAX(list of values) Maximum value 

MEDIAN(list of values) Median 

MIN(list of values) Minimum value 
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Table 2.16: Selection of SuperMix functions (continued) 

 

MODE(list of values) Mode 

SQRT(value) Square root 

SQUARE(value) Square 

 

2.5.4 Other useful data manipulations 

The data manipulation capabilities of the SuperMix spreadsheet window can be used 
to create interaction terms, essentially a product of variables, for use in modeling. It 
can also be used to perform grand mean centering of variables. 

 
Absolute references 

If you do not want SuperMix to adjust references when you copy a formula to a 
different cell, use an absolute reference. For example, if your formula multiplies 
cell A5 with cell C1 (=A5*C1) and you copy the formula to another cell, SuperMix will 
adjust both references. You can create an absolute reference to cell C1 by placing a 
dollar sign ($) before the parts of the reference that do not change. To create an 
absolute reference to cell C1, for example, add dollar signs to the formula as 
follows: = A5*$C$1. 

 
Creating an interaction term 

Suppose that we want to study the possible interaction between a subject's age and 
weight (in pounds). This product of Age and WT_lb, is created in the SuperMix 
spreadsheet window as follows. 

 

First, create a new column with header Age_WT. Then, select this column, and input 
the function (B1)*(E1) in the formula box. Click on the Apply button. Each value of 
the new variable Age_WT is equal to the product of the corresponding values of Age 
and WT_lb as shown below. 
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Grand mean centering 

It is often useful to center a predictor variable around its grand mean. To illustrate, 
we grand mean center the variable PFat. 
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To do so, first create a new column with the header of PFat_Mea. Then, select the 
PFat_Mea column, input the function (H1)-AVERAGE(H$1:H$15) in the formula box 
and click on the Apply button. Each value of the new variable of PFat_Mea now 
contains the difference between the corresponding original PFat value and the grand 
mean of all the PFat values. As illustrated below, the spreadsheet functions are not 
case sensitive. 

 

 


