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Why analyze as ordinal?

• Efficiency: Armstrong & Sloan (1989, Amer Jrn of Epid) and
Strömberg (1996, Amer Jrn of Epid) report efficiency losses be-
tween 49% to 87% when dichotomizing an ordinal outcome with
five categories.

• Bias: continuous model can yield correlated residuals and regres-
sors when used for ordinal outcomes; continuous model does not
take into account the ceiling and floor effects of the ordinal out-
come. Results in biased estimates of regression coefficients and is
most critical when the ordinal variables is highly skewed (see Bauer
& Sterba, 2011, Psych Methods)

• Logic: continuous model can yield predicted values outside of the
range of the ordinal variable.
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Ordinal Logistic Regression Model (aka Proportional
Odds or Cumulative Logit Model) - McCullagh (1980)

log


P (Y ≤ c)

1− P (Y ≤ c)

 = γc − x′β

c = 1, . . . , C − 1 for the C categories of the ordinal outcome
x = vector of explanatory variables (plus the intercept)
γc = threshold parameters; reflect cumulative logits when x = 0

(for identification: γ1 = 0 or β0 = 0)

• positive association between explanatory variable x and ordinal
outcome variable Y is reflected by β

• x is assumed to have the same effect on each cumulative logit
(proportional odds assumption)
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Ordinal Response and Threshold Concept

Continuous yi - unobservable latent variable - related to ordinal
response Yi via “threshold concept”

• threshold values γ1, γ2, . . . , γC−1 (γ0 = −∞ and γC =∞)

• C = number of ordered categories

Response occurs in category c, Yi = c if γc−1 < yi < γc
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The Threshold Concept in Practice

“How was your day?”
(what is your level of satisfaction today?)

• Satisfaction may be continuous, but we sometimes emit an
ordinal response:

5



Model for Latent Continuous Responses
Consider the model with p covariates for the latent response
strength yi (i = 1, 2, . . . , N):

yi = x′iβ + εi

• probit: εi ∼ standard normal (mean=0, variance=1)

• logistic: εi ∼ standard logistic (mean=0, variance=π2/3)

⇒ β estimates from logistic regression are larger (in abs. value)
than from probit regression by approximately

√
π2/3 = 1.8

Underlying latent variable

• useful way of thinking of the problem

• not an essential assumption of the model
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Mixed-effects ordinal logistic regression model
(Hedeker & Gibbons, 1994, 1996)

• i = 1, . . . N level-2 units (clusters or subjects)

• j = 1, . . . , ni level-1 units (subjects or repeated observations)

• c = 1, 2, . . . , C response categories

• Yij = ordinal response of level-2 unit i and level-1 unit j

How was your day? (asked repeatedly each day for a week)
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Mixed-effects ordinal logistic regression model

λijc = log


Pijc

(1− Pijc)

 = γc − (x′ijβ + z′ijυi)

• Pijc = Pr (Yij ≤ c | υ ; γc,β,Συ) = 1
1+exp(−λijc)

• pijc = Pr (Yij = c | υ ; γc,β,Συ) = Pijc − Pijc−1

• C − 1 strictly increasing model thresholds γc

• xij = p× 1 covariate vector

• zij = r × 1 design vector for random effects

• β = p× 1 fixed regression parameters

• υi = r × 1 random effects for level-2 unit i ∼ N(0,Συ)
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Model for Latent Continuous Responses

Model with p covariates for the latent response strength yij:

yij = x′ijβ + υ0i + εij

where υ0i ∼ N(0, σ2
υ), and assuming

• εij ∼ standard normal (mean 0 and σ2 = 1) leads to
mixed-effects ordinal probit regression

• εij ∼ standard logistic (mean 0 and σ2 = π2/3) leads to
mixed-effects ordinal logistic regression
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Underlying latent variable

• not an essential assumption of the model

• useful for obtaining intra-class correlation (r)

r =
σ2
υ

σ2
υ + σ2

and for design effect (d)

d =
σ2
υ + σ2

σ2 = 1/(1− r)

ratio of actual variance to the variance that would be obtained by
simple random sampling (holding sample size constant)
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Scaling of regression coefficients

Fixed-effects model
β estimates from logistic regression are larger (in abs. value) than
from probit regression by approximately√√√√√√√√π

2/3

1
= 1.8

because

• V (y) = σ2 = π2/3 for logistic

• V (y) = σ2 = 1 for probit

11



Mixed-effects model
β estimates from mixed-effects (random intercepts) model are larger
(in abs. value) than from fixed-effects model by approximately

√
d =

√√√√√√√√σ
2
υ + σ2

σ2

because

• V (y) = σ2
υ + σ2 in mixed-effects (random intercepts) model

• V (y) = σ2 in fixed-effects model

• difference depends on size of random-effects variance σ2
υ

• more complex for models with multiple random effects
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Treatment-Related Change Across Time

Data from the NIMH Schizophrenia collaborative study on treatment related
changes in overall severity. IMPS item 79, Severity of Illness, was scored as:

1 = normal or borderline mentally ill
2 = mildly or moderately ill
3 = markedly ill
4 = severely or among the most extremely ill

The experimental design and corresponding sample sizes:

Sample size at Week
Group 0 1 2 3 4 5 6 completers
PLC (n=108) 107 105 5 87 2 2 70 65%
DRUG (n=329) 327 321 9 287 9 7 265 81%
Drug = Chlorpromazine, Fluphenazine, or Thioridazine

Main question of interest:

•Was there differential improvement for the drug groups relative to the control
group?
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• Under SSI, Inc > “SuperMix (English)” or “SuperMix (English) Student”

• Under “File” click on “Open Spreadsheet”

• Open C:\SuperMixEn Examples\Workshop\Binary\SCHIZX1.ss3
(or C:\SuperMixEn Student Examples\Workshop\Binary\SCHIZX1.ss3)

14



C:\SuperMixEn Examples\Workshop\Binary\SCHIZX1.ss3
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Select Imps79O column, then “Edit” > “Set Missing Value”
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Select “File” > “Data-based Graphs” > “Bivariate”

17



18



Select “File” > “Data-based Graphs” > “Bivariate”
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Observed Logits across Time by Condition
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Within-Subjects / Between-Subjects components

Within-subjects model - level 1 (j = 1, . . . , ni obs)

λijc = γc − [b0i + b1i
√
Weekj]

Between-subjects model - level 2 (i = 1, . . . , N subjects)

b0i = β0 + β2Grpi + υ0i

b1i = β1 + β3Grpi + υ1i

υi ∼ NID(0,Συ)
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Under “File” click on “Open Existing Model Setup”

Open C:\SuperMixEn Examples\Workshop\Ordinal\schizo2.mum

(or C:\SuperMixEn Student Examples\Workshop\Ordinal\schizo2.mum)
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Note that “Dependent Variable Type” is “ordered”
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Note the lack of TxDrug as an explanatory variable
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Make sure “Optimization Method” is set to “adaptive quadrature”
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Note: Cumulative Logit link function
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Category response indicators (IMPS79O1-IMPS79O4); results of
fixed-effects model (to be ignored, or for comparison purposes)
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Model Fit of Observed Proportions
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SAS IML code: SCHZOFIT.SAS - computing marginal probabilities - ordinal model

adapted from syntax at http://www.uic.edu/classes/bstt/bstt513/ (Week 12)
TITLE1 ’NIMH Schizophrenia Data - Estimated Marginal Probabilities’;

PROC IML;

/* Results from random intercept and trend model */;

/* using Population Average Estimates */;

x0 = { 0.00000 0,

1.00000 0,

1.73205 0,

2.44949 0};
x1 = { 0.00000 0.00000,

1.00000 1.00000,

1.73205 1.73205,

2.44949 2.44949};

beta = { -.8041, -.9018};
thresh = {-4.5153, -1.726, .4765};
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za0 = (thresh[1] - x0*beta) ;

zb0 = (thresh[2] - x0*beta) ;

zc0 = (thresh[3] - x0*beta) ;

za1 = (thresh[1] - x1*beta) ;

zb1 = (thresh[2] - x1*beta) ;

zc1 = (thresh[3] - x1*beta) ;

grp0a = 1 / ( 1 + EXP(- za0));

grp0b = 1 / ( 1 + EXP(- zb0));

grp0c = 1 / ( 1 + EXP(- zc0));

grp1a = 1 / ( 1 + EXP(- za1));

grp1b = 1 / ( 1 + EXP(- zb1));

grp1c = 1 / ( 1 + EXP(- zc1));

print ’Random intercept and trend model’;

print using Population Average Estimates’;

print ’marginal prob for group 0 - catg 1’ grp0a [FORMAT=8.4];

print ’marginal prob for group 0 - catg 2’ (grp0b-grp0a) [FORMAT=8.4];

print ’marginal prob for group 0 - catg 3’ (grp0c-grp0b) [FORMAT=8.4];

print ’marginal prob for group 0 - catg 4’ (1-grp0c) [FORMAT=8.4];

print ’marginal prob for group 1 - catg 1’ grp1a [FORMAT=8.4];

print ’marginal prob for group 1 - catg 2’ (grp1b-grp1a) [FORMAT=8.4];

print ’marginal prob for group 1 - catg 3’ (grp1c-grp1b) [FORMAT=8.4];

print ’marginal prob for group 1 - catg 4’ (1-grp1c) [FORMAT=8.4];
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Proportional and Non-proportional Odds

Proportional Odds model

log


P (Yij ≤ c)

1− P (Yij ≤ c)

 = γc −
[
x′ijβ + z′ijυi

]

with υi ∼ N(0,Συ)

• relationship between the explanatory variables and the
cumulative logits does not depend on c

• effects of x variables DO NOT vary across the C − 1 cumulative
logits
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Non-Proportional/Partial Proportional Odds model

log


P (Yij ≤ c)

1− P (Yij ≤ c)

 = γ0c −
[
u′ijγc + x′ijβ + z′ijυi

]

uij = h× 1 vector for the set of h covariates for which proportional
odds is not assumed

• effects of u variables DO vary across the C − 1 cumulative logits

• more flexible model for ordinal response relations

• can be used to empirically test proportional odds assumption
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Proportional Odds Assumption: covariate effects are the
same across all cumulative logits

Response
group Absent Mild Severe total

control 27 46 27 100

cumulative odds 27
73 = .37 73

27 = 2.7

logit -1 1
treatment 38 44 18 100

cumulative odds 38
62 = .61 82

18 = 4.6

logit -.5 1.5

⇒ group difference = .5 for both cumulative logits
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Non-Proportional Odds: covariate effects vary across the
cumulative logits

Response
group Absent Mild Severe total

control 27 46 27 100

cumulative odds 27
73 = .37 73

27 = 2.7

logit -1 1
treatment 28 60 12 100

cumulative odds 28
72 = .39 88

12 = 7.3

logit -.95 2

⇒ UNEQUAL group difference across cumulative logits
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Open C:\SuperMixEn Examples\Workshop\Ordinal\schizo2np.mum

(or C:\SuperMixEn Student Examples\Workshop\Ordinal\schizo2np.mum)

’
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Note that “Dependent Variable Type” is “ordered”
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Two explanatory variables: SqrtWeek and Tx∗SWeek
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“Explanatory Variable Interactions” - both are selected
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Proportional Odds Assumption Accepted: χ2
4 = 3325.51− 3324.16 = 1.35

43



Linear Transforms

Fixed part of model:

λc = γ̂0c −
β̂1SqrtWeek + β̂2Tx*SWeek

+ γ̂1cSqrtWeek + γ̂2cTx*SWeek]

cumulative logit
variable 1 vs 2,3,4 1,2 vs 3,4 1,2,3, vs 4

SqrtWeek β̂1 β̂1 + γ̂12 β̂1 + γ̂13

Tx∗SWeek β̂2 β̂2 + γ̂22 β̂2 + γ̂23

H0 : β1 + γ12 = 0; SqrtWeek effect is 0 on the 2nd cumulative logit

z =
β̂1 + γ̂12

SE(β̂1 + γ̂12)
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NIMH Schiz Study: Severity of Illness (N = 437)
Ordinal LR Estimates (se) - random intercept and trend model

Proportional Non-Proportional
Odds Model Odds Model

1 vs 2,3,4 1,2 vs 3,4 1,2,3 vs 4
Time (sqrt week) −0.900 −0.951 −1.033 −0.834

(0.190) (0.331) (0.224) (0.206)

Drug by Time −1.674 −1.683 −1.603 −1.683
(0.208) (0.288) (0.229) (0.237)

−2 logL 3325.51 3324.16

• Proportional Odds accepted (χ2
4 = 3325.51− 3324.16 = 1.35)
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San Diego Homeless Research Project (Hough)

• 361 mentally ill subjects who were homeless or at very high risk
of becoming homeless

• 2 conditions: HUD Section 8 rental certificates (yes/no)

• baseline and 6, 12, and 24 month follow-ups

• Categorical outcome: housing status

– streets / shelters (Y = 0)

– community / institutions (Y = 1)

– independent (Y = 2)

Question: Do Section 8 certificates influence housing status across
time?
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• Under SSI, Inc > “SuperMix (English)” or “SuperMix (English) Student”

• Under “File” click on “Open Spreadsheet”

• Open C:\SuperMixEn Examples\Workshop\Nominal\SDHOUSE.ss3
(or C:\SuperMixEn Student Examples\Workshop\Nominal\SDHOUSE.ss3)
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C:\SuperMixEn Examples\Workshop\Nominal\SDHOUSE.ss3
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Select Housing column, then “Edit” > “Set Missing Value”
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Select “File” > “Data-based Graphs” > “Bivariate”
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Select “File” > “Data-based Graphs” > “Bivariate”
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Under “File” click on “Open Existing Model Setup”

Open C:\SuperMixEn Examples\Workshop\Ordinal\SDO1.mum
(or C:\SuperMixEn Student Examples\Workshop\Ordinal\SDO1.mum)
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Note that “Dependent Variable Type” is “ordered”
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All explanatory variables are indicator (dummy) variables
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Housing status across time: 1289 observations within 361 subjects
Ordinal Mixed Regression Model estimates and standard errors (se)

Proportional Odds Non-Proportional Odds
Non-street1 Independent2 difference

term estimate se estimate se estimate se estimate se
threshold1 .220 .198 .322 .207
threshold2 2.966 .230 2.700 .298

t1 (6 month) 1.736 .235 2.298 .303 1.079 .343 -1.219 .408
t2 (12 month) 2.316 .247 3.346 .387 1.645 .340 -1.701 .467
t3 (24 month) 2.500 .253 2.822 .348 2.145 .337 -.676 .422

section 8 (yes=1) .497 .277 .592 .294 .323 .394 -.269 .384

section 8 by t1 1.409 .341 .566 .467 2.024 .471 1.457 .581
section 8 by t2 1.173 .354 -.958 .506 2.017 .476 2.975 .600
section 8 by t3 .638 .349 -.366 .480 1.073 .464 1.440 .573

subject var 2.134 .354 2.128 .353 (ICC ≈ .4)

−2 logL 2274.39 2222.25 (χ2
7 = 52.14)

bold indicates p < .05 italic indicates .05 < p < .10
1 = independent + community vs street
2 = independent vs community + street
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For Non-Proportional Odds model, under “File” click on “Open Existing Model Setup”

Open C:\SuperMixEn Examples\Workshop\Ordinal\SDO2.mum
(or C:\SuperMixEn Student Examples\Workshop\Ordinal\SDO2.mum)
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Note that “Dependent Variable Type” is “ordered”
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Note “Explanatory Variable Interactions” is set to 7
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Mixed Multinomial Logistic Regression Model

Yij = nominal response of level-2 unit i and level-1 unit j

Which member of The Polkaholics is your favorite?
(asked before, during, and after a show)
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Mixed-effects Multinomial Logistic Regression Model

log
pijc
pij1

= u′ijγc + z′ijυic c = 2, 3, . . . C

• C − 1 contrasts to reference cell (c = 1)

• regression effects γc vary across contrasts

• random-effects υic vary across contrasts

– independent

– correlated

For example, with C = 3

contrast ordinal nominal
c1 2 & 3 vs 1 2 vs 1
c2 3 vs 1 & 2 3 vs 1
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Model in terms of the category probabilities

pijc = Pr(Yij = c | υic) =
exp(zijc)

1 + ∑C
h=2 exp(zijh)

for c = 2, 3, . . . , C

pij1 = Pr(Yij = 1 | υic) =
1

1 + ∑C
h=2 exp(zijh)

where the multinomial logit zijc = u′ijγc + z′ijυic
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Under “File” click on “Open Existing Model Setup”

Open C:\SuperMixEn Examples\Workshop\Nominal\sdhouse.mum
(or C:\SuperMixEn Student Examples\Workshop\Nominal\sdhouse.mum)
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Note that “Dependent Variable Type” is “nominal”
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Can select first or last category as the reference cell
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Try independent random effects first
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Now allow the random effects to be correlated
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LR test comparing models: χ2
1 = 2218.72− 2180.94 = 37.78
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Summary

Models for longitudinal ordinal and nominal data as developed as
models for continuous and dichotomous data

• Proportional odds models

• Non and partial proportional odds models

• Nominal models (with reference-cell contrasts)

• Grouped-time survival analysis models

⇒ SuperMix can do it all, including 3-level models, also for counts

• full likelihood solution using adaptive quadrature
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